IAcSmCalloutBlocks


The Sheet CalloutBlockReferences interface.

available methods :

(setq cad (vlax-get-acad-object))
(setq doc (vla-get-ActiveDocument cad))
(setq ssmgr (vla-GetInterfaceObject cad "BricscadSm.AcSmSheetSetMgr"))
(setq smdb (vlax-invoke-method ssmgr 'OpenDatabase dstfile))
(setq iter (vlax-invoke-method smdb 'GetEnumerator))
(setq calloutBlocks (scanUntilObject iter "AcSmCalloutBlocks"))

Note : "(scanUntilObject)" is a utility function contained in the sample Lisp files in folder "<LDSP>/SheetSetManager-Lisp-API/LISP Sample Code"

Add

adds the specified IAcSmAcDbBlockRecordReference component to this collection

(setq iter (vlax-invoke-method calloutBlocks 'GetEnumerator))
(setq firstBlock (vlax-invoke-method iter 'Next))
(vlax-invoke-method calloutBlocks 'Add firstBlock)

HRESULT Add ([in] IAcSmAcDbBlockRecordReference* pBlkRef)

Remove

removes the specified IAcSmAcDbBlockRecordReference component from this collection

(setq iter (vlax-invoke-method calloutBlocks 'GetEnumerator))
(setq firstBlock (vlax-invoke-method iter 'Next))
(vlax-invoke-method calloutBlocks 'Remove firstBlock)

HRESULT Remove ([in] IAcSmAcDbBlockRecordReference* pBlkRef)

GetEnumerator

returns an enumerator for the IAcSmAcDbBlockRecordReference components in this collection

(setq iter (vlax-invoke-method calloutBlocks 'GetEnumerator))

HRESULT GetEnumerator ([out, retval] IAcSmEnumAcDbBlockRecordReference** enumerator)



©  Bricsys NV. All rights reserved.