IAcSmSheetSet


The SheetSet interface.

available methods :

(setq cad (vlax-get-acad-object))
(setq doc (vla-get-ActiveDocument cad))
(setq ssmgr (vla-GetInterfaceObject cad "BricscadSm.AcSmSheetSetMgr"))
(setq smdb (vlax-invoke-method ssmgr 'OpenDatabase dstfile))
(setq iter (vlax-invoke-method smdb 'GetEnumerator))
(setq sheetset (vlax-invoke-method smdb 'GetSheetSet))

Note : "(scanUntilObject)" is a utility function contained in the sample Lisp files in folder "<LDSP>/SheetSetManager-Lisp-API/LISP Sample Code"

GetAltPageSetups

returns the IAcSmFileReference that references the drawing/template containing the alternative page setups

(setq res (vlax-invoke-method sheetset 'GetAltPageSetups))

HRESULT GetAltPageSetups ([out, retval] IAcSmFileReference** ppDwtRef)

SetAltPageSetups

assigns the IAcSmFileReference referencing the drawing/template containing the alternative page setups

(setq fileref (scanUntilObject iter "AcSmFileReference"))
(vlax-invoke-method sheetset 'SetAltPageSetups fileref)

HRESULT SetAltPageSetups ([in] IAcSmFileReference* pFileRef)

GetDefAltPageSetup

returns the IAcSmNamedAcDbObjectReference referencing the default page setup within the DWT that contains the alternative page setups

(setq res (vlax-invoke-method sheetset 'GetDefAltPageSetup))

HRESULT GetDefAltPageSetup ([out, retval] IAcSmNamedAcDbObjectReference** ppAltPageSetup)

SetDefAltPageSetup

assigns the IAcSmNamedAcDbObjectReference referencing the default page setup within the DWT that contains the alternative page setups

(setq layoutref (scanUntilObject iter "AcSmAcDbLayoutReference"))
(vlax-invoke-method sheetset 'SetDefAltPageSetup layoutref)

HRESULT SetDefAltPageSetup ([in] IAcSmNamedAcDbObjectReference* pAltPageSetup)

GetPromptForDwgName

returns whether the user interface should prompt for new drawing name

(setq res (vlax-invoke-method sheetset 'GetPromptForDwgName))

HRESULT GetPromptForDwgName ([out, retval] VARIANT_BOOL* askForName)

SetPromptForDwgName

defines whether the user interface should prompt for new drawing name

(vlax-invoke-method sheetset 'SetPromptForDwgName :vlax-true)

HRESULT SetPromptForDwgName ([in] VARIANT_BOOL askForName)

GetSheetSelSets

returns the collection of the sheet selection sets associated with this sheetset

(setq ssSelSet (vlax-invoke-method sheetset 'GetSheetSelSets))

HRESULT GetSheetSelSets ([out, retval] IAcSmSheetSelSets** ppSheetSelSets)

GetResources

returns the collection of the resources associated with this sheetset

(setq resources (vlax-invoke-method sheetset 'GetResources))

HRESULT GetResources ([out, retval] IAcSmResources** ppResources)

GetCalloutBlocks

returns the collection of callout block references associated with this sheetset

(setq callouts (vlax-invoke-method sheetset 'GetCalloutBlocks))

HRESULT GetCalloutBlocks ([out, retval] IAcSmCalloutBlocks** ppCalloutBlocks)

GetViewCategories

(reserved for future use) returns the collection of the view categories contained in this sheetset

(setq viewCats (vlax-invoke-method sheetset 'GetViewCategories))

HRESULT GetViewCategories ([out, retval] IAcSmViewCategories** ppViewCategories)

GetDefLabelBlk

returns the IAcSmAcDbBlockRecordReference that references the label block definition for this sheetset

(setq labelBlock (vlax-invoke-method sheetset 'GetDefLabelBlk))

HRESULT GetDefLabelBlk ([out, retval] IAcSmAcDbBlockRecordReference** ppLabelBlkRef)

SetDefLabelBlk

assigns the IAcSmAcDbBlockRecordReference that references the label block definition for this sheetset

(setq labelBlock (scanUntilObject iter "AcSmAcDbBlockRecordReference"))
(vlax-invoke-method sheetset 'SetDefLabelBlk labelBlock)

HRESULT SetDefLabelBlk ([in] IAcSmAcDbBlockRecordReference* pLabelBlkRef)

GetPublishOptions

returns the collection of the publish options contained in this sheetset

(setq options (vlax-invoke-method sheetset 'GetPublishOptions))

HRESULT GetPublishOptions ([out, retval] IAcSmPublishOptions** ppPublishOptions)

Sync

updates the sheet view components in this sheetset that are related to the provided AcDbDatabase

(setq db (vla-get-Database doc))
(vlax-invoke-method sheetset 'Sync db)

HRESULT Sync ([in] IAcadDatabase* pDb)

UpdateSheetCustomProps

updates custom properties associated with this sheetset

(vlax-invoke-method sheetset 'UpdateSheetCustomProps)

HRESULT UpdateSheetCustomProps ()



©  Bricsys NV. All rights reserved.