IAcSmSheetViews
The SheetViews interface.
available methods :
(setq cad (vlax-get-acad-object))
(setq doc (vla-get-ActiveDocument
cad))
(setq ssmgr (vla-GetInterfaceObject cad
"BricscadSm.AcSmSheetSetMgr"))
(setq smdb (vlax-invoke-method ssmgr
'OpenDatabase dstfile))
(vlax-invoke-method ssmgr "GetSheetFromLayout"
layout sheet)
(setq sheetviews (vlax-invoke-method sheet
'GetSheetViews))
Note : "(scanUntilObject)" is a utility
function contained in the sample Lisp files in folder
"<LDSP>/SheetSetManager-Lisp-API/LISP Sample Code"
GetEnumerator |
returns an enumerator for the
sheet views in this collection |
Sync |
updates the sheet views in
this collection that are related to the provided according to the
provided IAcSmAcDbLayoutReference in the specified
AcDbDatabase |
© Bricsys NV. All rights reserved. |