AddEllipse method

Creates a new ellipse and adds it to the drawing.

 

Syntax

objectVariable = object.AddEllipse(Center, MajorAxis, RadiusRatio)

Where:

     objectVariable is an Ellipse object;

     object is one of the ModelSpace or PaperSpace collection objects or a Block object;

     Center is a Variant representing the center of the ellipse;

     MajorAxis is a Variant  representing the orientation of the major axis (the line which defines the longest distance across an ellipse, from one end to the other;

     RadiusRatio is a double-precision variable or number defining the major to minor axis ratio of an ellipse. A radius ratio of 1.0 defines a circle.

 

Examples...

AddEllipse method example

 


© Bricsys NV. All rights reserved.