bim:create-namespace


(bim:create-namespace  nameSpace  label  visible)

This function creates a new PropertyNameSpace using specified nameSpace name and label for its GUI label.

Arguments

nameSpace  (string) the namespace to be removed (can be the "name" or the "label" of a BIM NameSpace)

label  (string) the GUI label for the NameSpace; if specified as empty string, the name will be used automatically

visible  (T/NIL)  specifies whether the nameSpace will be visible or hidden

Return

T or NIL, indicating success or failure

Example

(bim:create-namespace "MyPropertyNameSpace" "== MyNameSpace ===" T)  T
(bim:has-namespace "MyPropertyNameSpace")  T
(bim:has-namespace "=== MyNameSpace ===")  T

Remarks

the "visible" status means whether PropertySet(s) and Properties assigned to the specific namespace are visible in PropertiesPanel;
this function is tolerant : if the nameSpace already exists, T is returned



©  Bricsys NV. All rights reserved.