bim:delete-namespace


(bim:delete-namespace  nameSpace)

Deletes the specified nameSpace and all PropertySets.contained.

Arguments

nameSpace  (string) the namespace to be removed (can be the "name" or the "label" of a BIM NameSpace)

Return

T or NIL, indicating success or failure

Example

(bim:delete-namespace "MyPropertyNameSpace")  T
bim:delete-namespace "User")  T

Remarks

the nameSpace is not case-sensitive; both "name" and "label" of a BIM NameSpace are verified;
Note : all contained ProeprtySets are also removed !



©  Bricsys NV. All rights reserved.