bim:get-assigned-building


(bim:get-assigned-building  ename)

Returns the building name, to which the given entity is assigned to, or NIL if that entity is not assigned to a building object.

Arguments

ename  the entity to query, as normal entity or as VLA object name

Return

the building name (as string), or NIL if the entity is not assigned to a building object

Example

(bim:set-assigned-building ent "Building 1")  T
(bim:get-assigned-building ent)  "Building 1"

Remarks

see (bim:set-assigned-building)



©  Bricsys NV. All rights reserved.