bim:get-property


(bim:get-property  ename  propertyName  [categoryId | categoryName])

Returns the value of the specified property (string), for the specified entity.

Arguments

ename  the entity to query, as normal entity or as VLA object name

propertyName  name (string) of a property supported by the specific BIM Element type, as the entity is classified

categoryId  optional BIM property category ID, can be omitted (bcBimCategoryStandard is used then); see Category Constants
---or---
categoryName  optional BIM category name as string (can be an empty string for bcBimCategoryStandard), see Category Constants

Return

the value of the specified property (always as a native Lisp data type : string, integer, real etc.);
if the entity is not classified as a BIM Element, NIL is returned

Example

(bim:set-bimtype ent "Wall")  T
(bim:get-property ent "Combustible")  0
(bim:get-property ent "Combustible" bcBimCategoryStandard)  0
(bim:get-property ent "Combustible" bcBimCategoryIFCCustom)  NIL

Remarks

see (bim::set-property)
all property names are always case-sensitive !



©  Bricsys NV. All rights reserved.