bim:get-roomarea


(bim:get-roomarea  roomEntity)

Returns the area for the BIM room specified by "roomEntity".

Arguments

roomEntity  room entity of an existing room (ename), as returned by (bim::create-room) and (bim::create-associativeroom), or other room functions

Return

the room area (double/real) if "roomEntity" is a valid BIM room, or 0.0 otherwise

Example

(bim:get-roomarea roomEnt1)  55.80
(bim:get-roomarea roomEnt2x)  0.0

Remarks

see (bim::create-room), (bim::create-associativeroom), (bim:get-room) or (bim:get-allrooms)



©  Bricsys NV. All rights reserved.