bim:get-roomdepartment


(bim:get-roomdepartment  roomEntity)

Returns the description for the BIM room specified by "roomEntity".

Arguments

roomEntity  room entity of an existing room (ename), as returned by (bim::create-room) and (bim::create-associativeroom), or other room functions

Return

the room department (string) if "roomEntity" is a valid BIM room, or NIL otherwise

Example

(bim:get-roomdepartment roomEnt1)  "Level 1 inside Tower building"
(bim:get-roomdepartment roomEnt2x)  NIL

Remarks

see (bim::create-room), (bim::create-associativeroom), (bim:get-room) or (bim:get-allrooms)



©  Bricsys NV. All rights reserved.