bim:get-roomident


(bim:get-roomident  roomEntity)

Returns the room identification string for the BIM room specified by "roomEntity".

Arguments

roomEntity  room entity of an existing room (ename), as returned by (bim::create-room) and (bim::create-associativeroom), or other room functions

Return

the room identification (string) if "roomEntity" is a valid BIM room, or NIL otherwise;
this is a unique, internally created and persistent identification string for each room

Example

(bim:get-roomident roomEnt1)  "3eLi0Qc1rC$vZLPW4Wn4rp"
(bim:get-roomident roomEnt2x)  NIL

Remarks

see (bim::create-room), (bim::create-associativeroom), (bim:get-room) or (bim:get-allrooms)



©  Bricsys NV. All rights reserved.