bim:has-namespace


(bim:has-namespace  nameSpace)

Returns whether the specified nameSpace does exist..

Arguments

nameSpace  (string) the namespace to verify (can be the "name" or the "label" of a BIM NameSpace)

Return

T or NIL

Example

(bim:has-namespace "MyPropertyNameSpace")  NIL
(bim:has-namespace "User")  T
(bim:has-namespace "IFC2x3")  T
(bim:has-namespace "ifc2x3")  T

Remarks

the nameSpace is not case-sensitive; both "name" and "label" of a BIM NameSpace are verified



©  Bricsys NV. All rights reserved.