bim:has-propertyset


(bim:has-propertyset  name  [categoryId | categoryName])

Returns whether the specified PropertySet name does exist (in optionally specified NameSpace).

Arguments

name  (string) the name of the PropertySet to be deleted (can specify the "name" or the "label" of a PropertySet)

(optional)
specifies the NameSpace to where the PropertySet resides (each category has an associated NameSpace)
categoryId  BIM property category ID, can be omitted (bcBimCategoryUser is used then); see Category Constants
---or---
categoryName  BIM category name as string (can be an empty string for bcBimCategoryUser), see Category Constants

if omitted, the "User" NameSpace is automatically used

Return

T or NIL, indicating whether the PropertySet exists

Example

(bim:has-propertyset "TestSet")  NIL
(bim:create-propertyset "TestSet" "---test---" T T)  T
(bim:has-propertyset "TestSet")  T

Remarks

the PropertySet name/label is case-insensitive;
if the NameSpace (as indirectly specified by categoryId resp. categoryName) does not exist, NIL is returned;



©  Bricsys NV. All rights reserved.