The audit level is a positive integer that controls the amount of
error or warning messages that are displayed.
This is the meaning of the possible audit levels:
audit level 0
no error or warning messages will be
displayed
audit level 1
Only the most serious messages will be
displayed. For instance, this message will be displayed when trying
to display a dcl button using the function new_dialog: "Only a
dialog can be created without parent, not a button.". After that
message, nothing will be displayed. This is the default audit
level.
Another level 1 message warns about repetition of keys. For
instance, assigning the key my_button to two button tiles will
yield the message "The key 'my_button' was already assigned.".
Syntax errors happening while parsing the dcl input file, also are
level 1 error messages.
audit level 2
All messages of level 1 and messages
about wrong attribute values will be displayed. For instance, when
specifying the value "ellow" for the attribute color, this message
will be displayed: "Failed to create a color from colorcode: ellow.
Black will be used instead."
audit level 3
All messages of level 1 and 2 and
messages about redundant attribute values will be displayed. This
is an example of a level 3 message: "The attributes width, height
and aspect_ratio are specified together. The attribute aspect_ratio
will be ignored".
Every audit level contains at least all of lower level messages.
Currently audit level 4 does not contain additional messages as
opposed to audit level 3. So in audit level 3 or higher all
messages are displayed.