dictrename


(dictrename  dictEname  oldkey  newkey)

This function renames the dictionary entry with key oldkey to key newkey in dictionary dictEname.

Arguments

dictEname  the entity name (ENAME) of the dictionary

oldkey  they old dictionary entry (key its key string) to be renamed

newkey  they new dictionary entry (key its key string)

Return

returns newkey is successful, or NIL otherwise

Example

(dictrename (namedobjdict) "MyOldKey" "MyNewKey")

Remarks

fails if oldkey does not exist, or if newkey already exists;
see (dictadd) (dictsearch) (dictrename) (dictremove)



©  Bricsys NV. All rights reserved.