EntityGetSubentityPathsAtGraphicsMarker Method (SubentityType,
Int32, Point3d, Matrix3d, Int32, ObjectId)
|
Note: This API is now obsolete.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
[ObsoleteAttribute("Use the overload taking IntPtr instead.")]
public virtual FullSubentityPath[] GetSubentityPathsAtGraphicsMarker(
SubentityType type,
int gsMark,
Point3d pickPoint,
Matrix3d viewTransform,
int numInserts,
ObjectId[] entityAndInsertStack
)
<ObsoleteAttribute("Use the overload taking IntPtr instead.")>
Public Overridable Function GetSubentityPathsAtGraphicsMarker (
type As SubentityType,
gsMark As Integer,
pickPoint As Point3d,
viewTransform As Matrix3d,
numInserts As Integer,
entityAndInsertStack As ObjectId()
) As FullSubentityPath()
public:
[ObsoleteAttribute(L"Use the overload taking IntPtr instead.")]
virtual array<FullSubentityPath>^ GetSubentityPathsAtGraphicsMarker(
SubentityType type,
int gsMark,
Point3d pickPoint,
Matrix3d viewTransform,
int numInserts,
array<ObjectId>^ entityAndInsertStack
)
[<ObsoleteAttribute("Use the overload taking IntPtr instead.")>]
abstract GetSubentityPathsAtGraphicsMarker :
type : SubentityType *
gsMark : int *
pickPoint : Point3d *
viewTransform : Matrix3d *
numInserts : int *
entityAndInsertStack : ObjectId[] -> FullSubentityPath[]
[<ObsoleteAttribute("Use the overload taking IntPtr instead.")>]
override GetSubentityPathsAtGraphicsMarker :
type : SubentityType *
gsMark : int *
pickPoint : Point3d *
viewTransform : Matrix3d *
numInserts : int *
entityAndInsertStack : ObjectId[] -> FullSubentityPath[]
Parameters
- type
- Type: Teigha.DatabaseServicesSubentityType
- gsMark
- Type: SystemInt32
- pickPoint
- Type: Teigha.GeometryPoint3d
- viewTransform
- Type: Teigha.GeometryMatrix3d
- numInserts
- Type: SystemInt32
- entityAndInsertStack
- Type: Teigha.DatabaseServicesObjectId
Return Value
Type:
FullSubentityPath
See Also