Entity Class

Inheritance Hierarchy
Namespace:  Teigha.DatabaseServices
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public abstract class Entity : DBObject

The Entity type exposes the following members.

Constructors
  Name Description
Protected method Entity
Initializes a new instance of the Entity class
Top
Properties
  Name Description
Public property BlockId
Public property BlockName
Public property CastShadows
Public property CloneMeForDragging
Public property CollisionType
Public property Color
Public property ColorIndex
Public property CompoundObjectTransform
Public property Ecs
Public property EdgeStyleId
Public property EntityColor
Public property FaceStyleId
Public property ForceAnnoAllVisible
Public property GeometricExtents
Public property Hyperlinks
Public property IsPlanar
Public property Layer
Public property LayerId
Public property Linetype
Public property LinetypeId
Public property LinetypeScale
Public property LineWeight
Public property Material
Public property MaterialId
Public property MaterialMapper
Public property PlotStyleName
Public property PlotStyleNameId
Public property ReceiveShadows
Public property Transparency
Public property Visible
Public property VisualStyleId
Top
Methods
  Name Description
Public method AddSubentityPaths
Public method BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) Obsolete.
Public method BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr)
Public method BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) Obsolete.
Public method BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr)
Public method DeleteSubentityPaths
Public method Draw
Public method Explode
Public method ExplodeGeometry
Public method ExplodeGeometryToBlock(BlockTableRecord)
Public method ExplodeGeometryToBlock(BlockTableRecord, ObjectIdCollection)
Public method ExplodeGeometryToOwnerSpace
Public method GetGraphicsMarkersAtSubentityPathIntPtr
Public method GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection)
Public method GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags)
Public method GetGripPointsAtSubentityPath
Public method GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection)
Public method GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d)
Public method GetPlane
Public method GetStretchPoints
Public method GetSubentity
Public method GetSubentityGeometricExtents
Public method GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, ObjectId)
Public method GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, ObjectId) Obsolete.
Public method GetTransformedCopy
Public method Highlight
Public method Highlight(FullSubentityPath, Boolean)
Public method IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) Obsolete.
Public method IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr)
Public method IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) Obsolete.
Public method IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr)
Public method IsContentSnappable
Public method JoinEntities
Public method JoinEntity
Public method List
Public method MoveGripPointsAt(IntegerCollection, Vector3d)
Public method MoveGripPointsAt(IntPtr, Vector3d, MoveGripPointsFlags)
Public method MoveGripPointsAtSubentityPaths
Public method MoveStretchPointsAt
Public method RecordGraphicsModified
Public method SaveAs
Public method SetDatabaseDefaults
Public method SetDatabaseDefaults(Database)
Public method SetDragStatus
Public method SetGripStatus
Public method SetLayerId
Public method SetPropertiesFrom
Public method SetSubentityGripStatus
Public method TransformBy
Public method TransformSubentityPathsBy
Public method Unhighlight
Public method Unhighlight(FullSubentityPath, Boolean)
Top
Events
  Name Description
Top
See Also
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.GraphicsInterfaceDrawable
          Teigha.DatabaseServicesDBObject
            Teigha.DatabaseServicesEntity
              Bricscad.CivilAlignmentView
              Bricscad.CivilEntity
              Teigha.DatabaseServicesBlockBegin
              Teigha.DatabaseServicesBlockEnd
              Teigha.DatabaseServicesBlockReference
              Teigha.DatabaseServicesBody
              Teigha.DatabaseServicesCurve
              Teigha.DatabaseServicesDBPoint
              Teigha.DatabaseServicesDBText
              Teigha.DatabaseServicesDimension
              Teigha.DatabaseServicesFace
              Teigha.DatabaseServicesFeatureControlFrame
              Teigha.DatabaseServicesHatch
              Teigha.DatabaseServicesImage
              Teigha.DatabaseServicesLight
              Teigha.DatabaseServicesMLeader
              Teigha.DatabaseServicesMline
              Teigha.DatabaseServicesMPolygon
              Teigha.DatabaseServicesMText
              Teigha.DatabaseServicesOle2Frame
              Teigha.DatabaseServicesPolyFaceMesh
              Teigha.DatabaseServicesPolygonMesh
              Teigha.DatabaseServicesProxyEntity
              Teigha.DatabaseServicesRegion
              Teigha.DatabaseServicesSection
              Teigha.DatabaseServicesSequenceEnd
              Teigha.DatabaseServicesShape
              Teigha.DatabaseServicesSolid
              Teigha.DatabaseServicesSolid3d
              Teigha.DatabaseServicesSubDMesh
              Teigha.DatabaseServicesSurface
              Teigha.DatabaseServicesTrace
              Teigha.DatabaseServicesUnderlayReference
              Teigha.DatabaseServicesVertex
              Teigha.DatabaseServicesViewport

©  Bricsys NV. All rights reserved.