CircularArc3dSet Method (Point3d, Vector3d, Double)
|
Sets a circle's center, normal and
radius.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public void Set(
Point3d center,
Vector3d normal,
double radius
)
Public Sub Set (
center As Point3d,
normal As Vector3d,
radius As Double
)
public:
void Set(
Point3d center,
Vector3d normal,
double radius
)
member Set :
center : Point3d *
normal : Vector3d *
radius : float -> unit
Parameters
- center
- Type: Teigha.GeometryPoint3d
[in] Center of a circle.
- normal
- Type: Teigha.GeometryVector3d
[in] Normal vector of a 3D circle.
- radius
- Type: SystemDouble
[in] Radius of a circle.
See Also