Vector3d Structure |
The Vector3d type exposes the following members.
Name | Description | |
---|---|---|
![]() |
Vector3d(Double) |
Constructor for the Vector3d class. Creates a
new vector with coordinates taken from the first three values of
the passed array.
|
![]() |
Vector3d(PlanarEntity, Vector2d) |
Constructor for the Vector3d class. Creates a
new vector in the coordinates of the plane: uAxis * vect.x + vAxis
* vect.y where uAxis and vAxis are returned by plane.get(origin,
uAxis, vAxis).
|
![]() |
Vector3d(Double, Double, Double) |
Constructor for the Vector3d class. Creates a
new vector with coordinates specified by the x, y and z
values.
|
Name | Description | |
---|---|---|
![]() |
Coordinate | |
![]() |
LargestElement | |
![]() |
Length | |
![]() |
LengthSqrd | |
![]() |
X | |
![]() ![]() |
XAxis | |
![]() |
Y | |
![]() ![]() |
YAxis | |
![]() |
Z | |
![]() ![]() |
ZAxis |
Name | Description | |
---|---|---|
![]() |
Add |
Adds this vector to the specified
vector.
|
![]() |
AngleOnPlane |
Returns the angle of this vector projected
onto the specified plane.
|
![]() |
Convert2d |
Retrieves the 2D vector, in the coordinate
system of the plane, corresponding to the 3D vector.
|
![]() |
CrossProduct |
Returns the cross product of this vector and
the specified vector.
|
![]() |
DivideBy |
Divides coordinates of this vector by the
specified value.
|
![]() |
DotProduct |
Retrieves the dot product of this vector and
the specified vector.
|
![]() |
Equals |
Checks objects for equality.
(Overrides ValueTypeEquals(Object).) |
![]() |
GetAngleTo(Vector3d) |
Retrieves the angle between this vector and
the passed vector.
|
![]() |
GetAngleTo(Vector3d, Vector3d) | |
![]() |
GetHashCode |
Retrieves the object hash code.
(Overrides ValueTypeGetHashCode.) |
![]() |
GetNormal |
Retrieves the unit vector codirectional with
this vector.
|
![]() |
GetNormal(Tolerance) | |
![]() |
GetPerpendicularVector |
Retrieves a vector which is perpendicular to
this vector.
|
![]() |
GetType |
Gets the Type of the current instance.
(Inherited from Object.) |
![]() |
IsCodirectionalTo(Vector3d) |
Checks whether the specified vector is
codirectional to this vector.
|
![]() |
IsCodirectionalTo(Vector3d, Tolerance) |
Checks whether the specified vector is
codirectional to this vector within a geometric tolerance.
|
![]() |
IsEqualTo(Vector3d) |
Checks whether the passed vector is equal to
this vector. Vectors are considered equal if all coordinates of
this vector are the same as coordinates of the specified
vector.
|
![]() |
IsEqualTo(Vector3d, Tolerance) |
Checks whether the passed vector is equal to
this vector. Vectors are considered equal if all coordinates of
this vector are the same as coordinates of the specified vector
within geometric tolerance.
|
![]() |
IsParallelTo(Vector3d) |
Checks whether the passed vector is parallel
to this vector.
|
![]() |
IsParallelTo(Vector3d, Tolerance) |
Checks whether the passed vector is parallel
to this vector within a geometric tolerance.
|
![]() |
IsPerpendicularTo(Vector3d) |
Checks whether the passed vector is
perpendicular to this vector.
|
![]() |
IsPerpendicularTo(Vector3d, Tolerance) |
Checks whether the passed vector is
perpendicular to this vector within a geometric tolerance.
|
![]() |
IsUnitLength |
Checks whether this vector is 1.0.
|
![]() |
IsUnitLength(Tolerance) |
Checks whether this vector is 1.0 within a
geometric tolerance.
|
![]() |
IsZeroLength |
Checks whether this vector is 0.0.
|
![]() |
IsZeroLength(Tolerance) |
Checks whether this vector is 0.0 within a
geometric tolerance.
|
![]() |
Mirror |
Mirrors the entity about the plane passing
through the origin with the specified normal, and returns a
reference to the entity.
|
![]() |
MultiplyBy |
Multiplies coordinates of this vector by the
specified value.
|
![]() |
Negate |
Negates this vector by setting it to be equal
to the vector (-x, -y, -z).
|
![]() |
OrthoProjectTo |
Retrieves a 3D vector produced by the
orthogonal projection of this vector onto the plane with a
specified plane normal at the plane origin.
|
![]() |
ProjectTo |
Retrieves a 3D vector produced by the parallel
projection of this vector onto the plane with a specified plane
normal at the plane origin.
|
![]() |
RotateBy |
Rotates this vector by the specified angle
about the specified axis.
|
![]() |
Subtract |
Subtracts a passed vector from this
vector.
|
![]() |
ToArray | |
![]() |
ToString |
Returns a string representation of this
object.
(Overrides ValueTypeToString.) |
![]() |
ToString(IFormatProvider) | |
![]() |
ToString(String, IFormatProvider) | |
![]() |
TransformBy |
Name | Description | |
---|---|---|
![]() ![]() |
Addition |
Addition operator for the Vector3d
class.
|
![]() ![]() |
Division |
Division operator for the Vector3d
class.
|
![]() ![]() |
Equality |
Equality operator for the Vector3d
class.
|
![]() ![]() |
Inequality |
Inequality operator for the Vector3d
class.
|
![]() ![]() |
Multiply(Double, Vector3d) |
Multiplication operator for the Vector3d
class.
|
![]() ![]() |
Multiply(Matrix3d, Vector3d) |
Multiplication operator for the Vector3d
class.
|
![]() ![]() |
Multiply(Vector3d, Double) |
Multiplication operator for the Vector3d
class.
|
![]() ![]() |
Subtraction |
Subtraction operator for the Vector3d
class.
|
![]() ![]() |
UnaryNegation |
Negation operator for the Vector3d
class.
|
© Bricsys NV. All rights reserved. |