Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public void RayTest(
Point3d rayBasePoint,
Vector3d rayDir,
double rayRadius,
out SubentityId[] subEntIds,
out DoubleCollection parameters
)
Public Sub RayTest (
rayBasePoint As Point3d,
rayDir As Vector3d,
rayRadius As Double,
<OutAttribute> ByRef subEntIds As SubentityId(),
<OutAttribute> ByRef parameters As DoubleCollection
)
public:
void RayTest(
Point3d rayBasePoint,
Vector3d rayDir,
double rayRadius,
[OutAttribute] array<SubentityId>^% subEntIds,
[OutAttribute] DoubleCollection^% parameters
)
member RayTest :
rayBasePoint : Point3d *
rayDir : Vector3d *
rayRadius : float *
subEntIds : SubentityId[] byref *
parameters : DoubleCollection byref -> unit
Parameters
- rayBasePoint
- Type: Teigha.GeometryPoint3d
- rayDir
- Type: Teigha.GeometryVector3d
- rayRadius
- Type: SystemDouble
- subEntIds
- Type: Teigha.DatabaseServicesSubentityId
- parameters
- Type: Teigha.GeometryDoubleCollection
See Also