Matrix2dAlignCoordinateSystem Method
|
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public static Matrix2d AlignCoordinateSystem(
Point2d fromOrigin,
Vector2d fromE0,
Vector2d fromE1,
Point2d toOrigin,
Vector2d toE0,
Vector2d toE1
)
Public Shared Function AlignCoordinateSystem (
fromOrigin As Point2d,
fromE0 As Vector2d,
fromE1 As Vector2d,
toOrigin As Point2d,
toE0 As Vector2d,
toE1 As Vector2d
) As Matrix2d
public:
static Matrix2d AlignCoordinateSystem(
Point2d fromOrigin,
Vector2d fromE0,
Vector2d fromE1,
Point2d toOrigin,
Vector2d toE0,
Vector2d toE1
)
static member AlignCoordinateSystem :
fromOrigin : Point2d *
fromE0 : Vector2d *
fromE1 : Vector2d *
toOrigin : Point2d *
toE0 : Vector2d *
toE1 : Vector2d -> Matrix2d
Parameters
- fromOrigin
- Type: Teigha.GeometryPoint2d
- fromE0
- Type: Teigha.GeometryVector2d
- fromE1
- Type: Teigha.GeometryVector2d
- toOrigin
- Type: Teigha.GeometryPoint2d
- toE0
- Type: Teigha.GeometryVector2d
- toE1
- Type: Teigha.GeometryVector2d
Return Value
Type:
Matrix2d
See Also