Matrix2d Structure |
The Matrix2d type exposes the following members.
Name | Description | |
---|---|---|
![]() |
CoordinateSystem2d | |
![]() |
ElementAt | |
![]() |
Translation |
Name | Description | |
---|---|---|
![]() ![]() |
AlignCoordinateSystem | |
![]() ![]() |
Displacement | |
![]() |
Equals | (Overrides ValueTypeEquals(Object).) |
![]() |
GetDeterminant | |
![]() |
GetHashCode | (Overrides ValueTypeGetHashCode.) |
![]() |
![]() |
Inverse | |
![]() |
IsConformal | |
![]() |
IsEqualTo(Matrix2d) | |
![]() |
IsEqualTo(Matrix2d, Tolerance) | |
![]() |
IsScaledOrtho | |
![]() |
IsScaledOrtho(Tolerance) | |
![]() |
IsSingular | |
![]() |
IsSingular(Tolerance) | |
![]() |
IsUniscaledOrtho | |
![]() |
IsUniscaledOrtho(Tolerance) | |
![]() ![]() |
Mirroring(Line2d) | |
![]() ![]() |
Mirroring(Point2d) | |
![]() |
Multiply | |
![]() |
PostMultiplyBy | |
![]() |
PreMultiplyBy | |
![]() ![]() |
Rotation | |
![]() ![]() |
Scaling | |
![]() |
ToArray | |
![]() |
ToString | (Overrides ValueTypeToString.) |
![]() |
ToString(IFormatProvider) | |
![]() |
ToString(String, IFormatProvider) | |
![]() |
Transpose |
Name | Description | |
---|---|---|
![]() ![]() |
Equality | |
![]() ![]() |
Inequality | |
![]() ![]() |
Multiply |
© Bricsys NV. All rights reserved. |