Matrix3dAlignCoordinateSystem Method
|
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public static Matrix3d AlignCoordinateSystem(
Point3d fromOrigin,
Vector3d fromXAxis,
Vector3d fromYAxis,
Vector3d fromZAxis,
Point3d toOrigin,
Vector3d toXAxis,
Vector3d toYAxis,
Vector3d toZAxis
)
Public Shared Function AlignCoordinateSystem (
fromOrigin As Point3d,
fromXAxis As Vector3d,
fromYAxis As Vector3d,
fromZAxis As Vector3d,
toOrigin As Point3d,
toXAxis As Vector3d,
toYAxis As Vector3d,
toZAxis As Vector3d
) As Matrix3d
public:
static Matrix3d AlignCoordinateSystem(
Point3d fromOrigin,
Vector3d fromXAxis,
Vector3d fromYAxis,
Vector3d fromZAxis,
Point3d toOrigin,
Vector3d toXAxis,
Vector3d toYAxis,
Vector3d toZAxis
)
static member AlignCoordinateSystem :
fromOrigin : Point3d *
fromXAxis : Vector3d *
fromYAxis : Vector3d *
fromZAxis : Vector3d *
toOrigin : Point3d *
toXAxis : Vector3d *
toYAxis : Vector3d *
toZAxis : Vector3d -> Matrix3d
Parameters
- fromOrigin
- Type: Teigha.GeometryPoint3d
- fromXAxis
- Type: Teigha.GeometryVector3d
- fromYAxis
- Type: Teigha.GeometryVector3d
- fromZAxis
- Type: Teigha.GeometryVector3d
- toOrigin
- Type: Teigha.GeometryPoint3d
- toXAxis
- Type: Teigha.GeometryVector3d
- toYAxis
- Type: Teigha.GeometryVector3d
- toZAxis
- Type: Teigha.GeometryVector3d
Return Value
Type:
Matrix3d
See Also