Vector3dOrthoProjectTo Method

Retrieves a 3D vector produced by the orthogonal projection of this vector onto the plane with a specified plane normal at the plane origin.
Namespace:  Teigha.Geometry
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public Vector3d OrthoProjectTo(
        Vector3d planeNormal
)

Parameters

planeNormal
Type: Teigha.GeometryVector3d
[in] A 3D vector that is a normal vector of a plane on which this vector is projected.

Return Value

Type: Vector3d
3D vector that is the result of the orthogonal projection of this vector into the plane with a normal planeNormal passing through the origin.
See Also

©  Bricsys NV. All rights reserved.