EllipticalArc3dSet Method (Point3d, Vector3d, Vector3d, Double, Double,
Double, Double)
|
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public void Set(
Point3d center,
Vector3d majorAxis,
Vector3d minorAxis,
double majorRadius,
double minorRadius,
double startAngle,
double endAngle
)
Public Sub Set (
center As Point3d,
majorAxis As Vector3d,
minorAxis As Vector3d,
majorRadius As Double,
minorRadius As Double,
startAngle As Double,
endAngle As Double
)
public:
void Set(
Point3d center,
Vector3d majorAxis,
Vector3d minorAxis,
double majorRadius,
double minorRadius,
double startAngle,
double endAngle
)
member Set :
center : Point3d *
majorAxis : Vector3d *
minorAxis : Vector3d *
majorRadius : float *
minorRadius : float *
startAngle : float *
endAngle : float -> unit
Parameters
- center
- Type: Teigha.GeometryPoint3d
- majorAxis
- Type: Teigha.GeometryVector3d
- minorAxis
- Type: Teigha.GeometryVector3d
- majorRadius
- Type: SystemDouble
- minorRadius
- Type: SystemDouble
- startAngle
- Type: SystemDouble
- endAngle
- Type: SystemDouble
See Also