Curve3dGetDistanceTo Method (Point3d, Tolerance)
|
Retrieves the distance of the closest point on
this curve and the specified point within a specified
tolerance.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public double GetDistanceTo(
Point3d point,
Tolerance tolerance
)
Public Function GetDistanceTo (
point As Point3d,
tolerance As Tolerance
) As Double
public:
double GetDistanceTo(
Point3d point,
Tolerance tolerance
)
member GetDistanceTo :
point : Point3d *
tolerance : Tolerance -> float
Parameters
- point
- Type: Teigha.GeometryPoint3d
[in] Point to which the distance is calculated.
- tolerance
- Type: Teigha.GeometryTolerance
[in] Geometric tolerance.
Return Value
Type:
Double
The distance as a value of the double type.
See Also