Curve3d Class |
The Curve3d type exposes the following members.
Name | Description | |
---|---|---|
![]() |
AutoDelete | (Inherited from DisposableWrapper.) |
![]() |
BoundBlock | |
![]() |
EndPoint | |
![]() |
HasEndPoint | |
![]() |
HasStartPoint | |
![]() |
IsDisposed | (Inherited from DisposableWrapper.) |
![]() |
OrthoBoundBlock | |
![]() |
StartPoint | |
![]() |
UnmanagedObject | (Inherited from DisposableWrapper.) |
Name | Description | |
---|---|---|
![]() |
Clone | (Inherited from Entity3d.) |
![]() ![]() |
Create |
Creates a Curve3d object based on the passed
pointer.
|
![]() |
CreateObjRef |
Creates an object that contains all the
relevant information required to generate a proxy used to
communicate with a remote object.
(Inherited from MarshalByRefObject.) |
![]() |
DeleteUnmanagedObject | (Inherited from Entity3d.) |
![]() |
Dispose | (Inherited from DisposableWrapper.) |
![]() |
Dispose(Boolean) | (Inherited from DisposableWrapper.) |
![]() |
Equals | (Inherited from DisposableWrapper.) |
![]() |
EvaluatePoint |
Retrieves the point on the curve corresponding
to the specified parameter value.
|
![]() |
Explode |
Explodes the curve into its component
sub-curves.
|
![]() |
Finalize | (Inherited from DisposableWrapper.) |
![]() |
GetArea(Double, Double) |
Retrieves the area of the parametric interval
defined by the passed start and end parameters.
|
![]() |
GetArea(Double, Double, Tolerance) |
Retrieves the area of the parametric interval
defined by the passed start and end parameters.
|
![]() |
GetBoundBlockOf |
Retrieves the oriented bounding box of the
specified sub-interval of this curve.
|
![]() |
GetClosestPointTo(Curve3d) |
Retrieves the closest points between this
curve and the passed curve.
|
![]() |
GetClosestPointTo(Point3d) |
Retrieves the closest point on this curve to
the specified point.
|
![]() |
GetClosestPointTo(Curve3d, Tolerance) |
Retrieves the closest points between this
curve and the passed curve within a specified tolerance.
|
![]() |
GetClosestPointTo(Point3d, Tolerance) |
Retrieves the closest point on this curve to
the specified point within a specified tolerance.
|
![]() |
GetDistanceTo(Curve3d) |
Retrieves the distance of the closest points
between this curve and the passed curve.
|
![]() |
GetDistanceTo(Point3d) |
Retrieves the distance of the closest point on
this curve and the specified point.
|
![]() |
GetDistanceTo(Curve3d, Tolerance) |
Retrieves the distance of the closest points
between this curve and the passed curve within a specified
tolerance.
|
![]() |
GetDistanceTo(Point3d, Tolerance) |
Retrieves the distance of the closest point on
this curve and the specified point within a specified
tolerance.
|
![]() |
GetHashCode | (Inherited from DisposableWrapper.) |
![]() |
GetInterval |
Retrieves the parametric interval of this
curve.
|
![]() |
GetLength |
Retrieves the arc length of the curve between
the two parameter values.
|
![]() |
GetLifetimeService |
Retrieves the current lifetime service object
that controls the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() |
GetNormalPoint(Point3d) |
Retrieves the point on this curve where normal
extends through the passed point.
|
![]() |
GetNormalPoint(Point3d, Tolerance) |
Retrieves the point on this curve where normal
extends through the passed point within the specified
tolerance.
|
![]() |
GetOrthoBoundBlockOf |
Retrieves the bounding box of the specified
parametric range of this curve. Bounding box sides are parallel to
the coordinate axes.
|
![]() |
GetOrthoProjectEntity(Plane) |
Retrieves the entity representing the curve's
orthogonal projection onto the projection plane.
|
![]() |
GetOrthoProjectEntity(Plane, Tolerance) |
Retrieves the entity representing the curve's
orthogonal projection onto the projection plane.
|
![]() |
GetParameterAtLength |
Retrieves the parameter value of the point
whose arc length distance is the input length.
|
![]() |
GetParameterOf(Point3d) |
Retrieves the parameter value of a
point.
|
![]() |
GetParameterOf(Point3d, Tolerance) |
Retrieves the parameter value of a point
within a specified tolerance.
|
![]() |
GetProjectedClosestPointTo(Curve3d, Vector3d) |
Retrieves the point on this curve closest to
the specified curve, and the point on the passed curve closest to
this curve, when this curve is projected in the specified
direction.
|
![]() |
GetProjectedClosestPointTo(Point3d, Vector3d) |
Retrieves the point on this curve closest to
the specified point when projected in the specified
direction.
|
![]() |
GetProjectedClosestPointTo(Curve3d, Vector3d, Tolerance) |
Retrieves the points on this curve closest to
the specified curve, and the point on the other curve closest to
this curve, when this curve is projected in the specified
direction.
|
![]() |
GetProjectedClosestPointTo(Point3d, Vector3d, Tolerance) |
Retrieves the point on this curve closest to
the specified point when projected in the specified
direction.
|
![]() |
GetProjectedEntity(Plane, Vector3d) |
Retrieves the entity representing the curve's
projection onto the projection plane.
|
![]() |
GetProjectedEntity(Plane, Vector3d, Tolerance) |
Retrieves the entity representing the curve's
projection onto the projection plane.
|
![]() |
GetReverseParameterCurve |
Reverses the parameter *direction* of this
*curve*.
|
![]() |
GetSamplePoints(Int32) |
Retrieves an array of sample points along this
curve.
|
![]() |
GetSamplePoints(Double, Double, Double) |
Retrieves specified arrays of sample points
along this curve and their parameter values.
|
![]() |
GetSplitCurves |
Retrieves two segments of this curve split at
the specified parameter value.
|
![]() |
GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType) |
Receives one or more offset curves that
represent the trimmed offset of the curve.
|
![]() |
GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType, Tolerance) |
Receives one or more offset curves that
represent the trimmed offset of the curve.
|
![]() |
GetType |
Gets the Type of the current instance.
(Inherited from Object.) |
![]() |
InitializeLifetimeService |
Obtains a lifetime service object to control
the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() |
IsClosed |
Checks whether the curve is closed.
|
![]() |
IsClosed(Tolerance) |
Checks whether the curve is closed within a
specified tolerance.
|
![]() |
IsCoplanarWith(Curve3d, Plane) |
Checks whether the specified curve entity is
coplanar with this curve and returns the common plane.
|
![]() |
IsCoplanarWith(Curve3d, Plane, Tolerance) |
Checks whether the specified curve entity is
coplanar with this curve and returns the common plane.
|
![]() |
IsDegenerate(Entity3d) |
Checks whether this curve is degenerate and
returns the type of entity that the curve degenerates to (if
degenerate).
|
![]() |
IsDegenerate(Entity3d, Tolerance) |
Checks whether this curve is degenerate and
returns the type of entity that the curve degenerates to (if
degenerate).
|
![]() |
IsEqualTo(Entity3d) | (Inherited from Entity3d.) |
![]() |
IsEqualTo(Entity3d, Tolerance) | (Inherited from Entity3d.) |
![]() |
IsLinear(Line3d) |
Checks whether this curve is linear.
|
![]() |
IsLinear(Line3d, Tolerance) |
Checks whether this curve is linear within a
specified tolerance.
|
![]() |
IsOn(Double) |
Checks whether a specified parameter value is
within a valid parametric range of the curve.
|
![]() |
IsOn(Point3d) |
Checks whether a specified point lies on this
curve.
|
![]() |
IsOn(Double, Tolerance) |
Checks whether a specified parameter value is
within a valid parametric range of the curve.
|
![]() |
IsOn(Point3d, Double) |
Checks whether a specified point lies on this
curve.
|
![]() |
IsOn(Point3d, Tolerance) |
Checks whether a specified point lies on this
curve within a specified tolerance.
|
![]() |
IsOn(Point3d, Double, Tolerance) |
Checks whether a specified point lies on this
curve.
|
![]() |
IsPeriodic |
Checks whether the curve is periodic.
|
![]() |
IsPlanar(Plane) |
Checks whether this curve is planar. If the
curve is a line, this function returns an arbitrary plane that
contains the line. The plane parameter contains meaningful data
only if this function returns a value of true.
|
![]() |
IsPlanar(Plane, Tolerance) |
Checks whether this curve is planar within a
specified tolerance. If the curve is a line, this function returns
an arbitrary plane that contains the line. The plane parameter
contains meaningful data only if this function returns a value of
true.
|
![]() |
MemberwiseClone |
Creates a shallow copy of the current Object.
(Inherited from Object.) |
![]() |
MemberwiseClone(Boolean) |
Creates a shallow copy of the current MarshalByRefObject object.
(Inherited from MarshalByRefObject.) |
![]() |
Mirror | (Inherited from Entity3d.) |
![]() |
RotateBy | (Inherited from Entity3d.) |
![]() |
ScaleBy | (Inherited from Entity3d.) |
![]() |
SetInterval |
Sets the parametric range of this curve.
|
![]() |
ToString |
Returns a string that represents the current
object.
(Inherited from Object.) |
![]() |
TransformBy | (Inherited from Entity3d.) |
![]() |
TranslateBy | (Inherited from Entity3d.) |
© Bricsys NV. All rights reserved. |