CoordinateSystem2d Constructor
|
Constructor for the CoordinateSystem2d
structure.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public CoordinateSystem2d(
Point2d o,
Vector2d x,
Vector2d y
)
Public Sub New (
o As Point2d,
x As Vector2d,
y As Vector2d
)
public:
CoordinateSystem2d(
Point2d o,
Vector2d x,
Vector2d y
)
new :
o : Point2d *
x : Vector2d *
y : Vector2d -> CoordinateSystem2d
Parameters
- o
- Type: Teigha.GeometryPoint2d
[in] Coordinate system origin.
- x
- Type: Teigha.GeometryVector2d
[in] Defines the positive direction of the x-axis of this
system.
- y
- Type: Teigha.GeometryVector2d
[in] Defines the positive direction of the y-axis of this
system.
See Also