CircularArc3dSet Method (Point3d, Vector3d, Vector3d, Double, Double,
Double)
|
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public void Set(
Point3d center,
Vector3d normal,
Vector3d referenceVector,
double radius,
double startAngle,
double endAngle
)
Public Sub Set (
center As Point3d,
normal As Vector3d,
referenceVector As Vector3d,
radius As Double,
startAngle As Double,
endAngle As Double
)
public:
void Set(
Point3d center,
Vector3d normal,
Vector3d referenceVector,
double radius,
double startAngle,
double endAngle
)
member Set :
center : Point3d *
normal : Vector3d *
referenceVector : Vector3d *
radius : float *
startAngle : float *
endAngle : float -> unit
Parameters
- center
- Type: Teigha.GeometryPoint3d
- normal
- Type: Teigha.GeometryVector3d
- referenceVector
- Type: Teigha.GeometryVector3d
- radius
- Type: SystemDouble
- startAngle
- Type: SystemDouble
- endAngle
- Type: SystemDouble
See Also