Retrieves a 3D vector produced by the parallel
projection of this vector onto the plane with a specified plane
normal at the plane origin.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public Vector3d ProjectTo(
Vector3d planeNormal,
Vector3d projectDirection
)
Public Function ProjectTo (
planeNormal As Vector3d,
projectDirection As Vector3d
) As Vector3d
public:
Vector3d ProjectTo(
Vector3d planeNormal,
Vector3d projectDirection
)
member ProjectTo :
planeNormal : Vector3d *
projectDirection : Vector3d -> Vector3d
Parameters
- planeNormal
- Type: Teigha.GeometryVector3d
[in] Plane normal.
- projectDirection
- Type: Teigha.GeometryVector3d
[in] Projection direction.
Return Value
Type:
Vector3d
Projected 3D vector.
See Also