Assoc3dVariablegetByName Method
|
returns the constraint variable from specified
block table record, by variable's name
Namespace: Bricscad.Geometrical3dConstraints
Assembly: BrxMgd (in BrxMgd.dll) Version:
21.0.0.15598
Syntax
public static Assoc3dVariable getByName(
ObjectId blockId,
string name,
bool createIfNotExist
)
Public Shared Function getByName (
blockId As ObjectId,
name As String,
createIfNotExist As Boolean
) As Assoc3dVariable
public:
static Assoc3dVariable^ getByName(
ObjectId blockId,
String^ name,
bool createIfNotExist
)
static member getByName :
blockId : ObjectId *
name : string *
createIfNotExist : bool -> Assoc3dVariable
Parameters
- blockId
- Type: Teigha.DatabaseServicesObjectId
ObjectId of the block table record
- name
- Type: SystemString
name of the variable
- createIfNotExist
- Type: SystemBoolean
if 'true' and the 3D constraints group does not exist, it will be
created
Return Value
Type:
Assoc3dVariable
Returns Assoc3dVariable
See Also