Assoc3dVariable Class

Inheritance Hierarchy
Namespace:  Bricscad.Geometrical3dConstraints
Assembly:  BrxMgd (in BrxMgd.dll) Version: 21.0.0.15598
Syntax
public class Assoc3dVariable : DisposableWrapper

The Assoc3dVariable type exposes the following members.

Properties
  Name Description
Public property Expression
returns and sets the expression of this constraint variable
Public property isAnonymous
returns whether this constraint variable is anonymous or not
Public property Name
returns and sets the name of this constraint variable
Public property Value
returns the last successful result of expression evaluation of this constraint variable
Top
Methods
  Name Description
Protected method DeleteUnmanagedObject (Overrides DisposableWrapperDeleteUnmanagedObject.)
Public method erase
erase this constraints variable
Public method getBlockId
returns the owner block table record of this constraint variable
Public methodStatic member getByName
returns the constraint variable from specified block table record, by variable's name
Public methodStatic member getFromBlock
returns all constraint variables from specified block table record
Top
See Also

©  Bricsys NV. All rights reserved.