CubicSplineCurve3d Constructor (Point3dCollection, Vector3d,
Vector3d, Tolerance)
|
Constructor for the CubicSplineCurve2d class.
Creates a cubic spline curve according to the passed
parameters.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public CubicSplineCurve3d(
Point3dCollection points,
Vector3d startDerivative,
Vector3d endDerivative,
Tolerance tolerance
)
Public Sub New (
points As Point3dCollection,
startDerivative As Vector3d,
endDerivative As Vector3d,
tolerance As Tolerance
)
public:
CubicSplineCurve3d(
Point3dCollection^ points,
Vector3d startDerivative,
Vector3d endDerivative,
Tolerance tolerance
)
new :
points : Point3dCollection *
startDerivative : Vector3d *
endDerivative : Vector3d *
tolerance : Tolerance -> CubicSplineCurve3d
Parameters
- points
- Type: Teigha.GeometryPoint3dCollection
[in] Array of fit points.
- startDerivative
- Type: Teigha.GeometryVector3d
[in] Starting derivative of the cubic spline curve.
- endDerivative
- Type: Teigha.GeometryVector3d
[in] Ending derivative of the cubic spline curve.
- tolerance
- Type: Teigha.GeometryTolerance
[in] Geometric tolerance.
See Also