AcadMInsertBlockClass Class

Inheritance Hierarchy
SystemObject
  BricscadDbAcadMInsertBlockClass
Namespace:  BricscadDb
Assembly:  Interop.BricscadDb (in Interop.BricscadDb.dll) Version: 21.0.0.0
Syntax
public class AcadMInsertBlockClass : IAcadMInsertBlock, 
        AcadMInsertBlock, IAcadObjectEvents_Event

The AcadMInsertBlockClass type exposes the following members.

Constructors
  Name Description
Public method AcadMInsertBlockClass
Initializes a new instance of the AcadMInsertBlockClass class
Top
Properties
Methods
  Name Description
Public method add_Modified
Public method ArrayPolar
Public method ArrayRectangular
Public method ConvertToAnonymousBlock
Public method ConvertToStaticBlock
Public method Copy
Public method Delete
Public method Erase
Public method Explode
Public method GetAttributes
Public method GetBoundingBox
Public method GetConstantAttributes
Public method GetDynamicBlockProperties
Public method GetExtensionDictionary
Public method GetXData
Public method Highlight
Public method IntersectWith
Public method Mirror
Public method Mirror3D
Public method Move
Public method remove_Modified
Public method ResetBlock
Public method Rotate
Public method Rotate3D
Public method ScaleEntity
Public method SetXData
Public method TransformBy
Public method Update
Top
Events
  Name Description
Public event Modified
Top
See Also

©  Bricsys NV. All rights reserved.