ClipBoundary2dSet Method (Point2d, Point2d)
|
Resets the object to a rectangular clipping
boundary.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public ClipError Set(
Point2d firstCorner,
Point2d secondCorner
)
Public Function Set (
firstCorner As Point2d,
secondCorner As Point2d
) As ClipError
public:
ClipError Set(
Point2d firstCorner,
Point2d secondCorner
)
member Set :
firstCorner : Point2d *
secondCorner : Point2d -> ClipError
Parameters
- firstCorner
- Type: Teigha.GeometryPoint2d
[in] First corner point.
- secondCorner
- Type: Teigha.GeometryPoint2d
[in] Second corner point.
Return Value
Type:
ClipError
The ClipError object that represents the result of method
execution.
Remarks
Returned value
can one of the following:
Value |
Description |
OK |
No errors occurred. |
InvalidClipBoundary |
Invalid clipping boundary. |
NotInitialized |
Clipping boundary was not initialized. |
See Also