ClipBoundary2d Class

This .NET class wraps the OdGeClipBoundary2d class.
Inheritance Hierarchy
Namespace:  Teigha.Geometry
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public sealed class ClipBoundary2d : Entity2d

The ClipBoundary2d type exposes the following members.

Constructors
  Name Description
Public method ClipBoundary2d
Default constructor for the ClipBoundary2d class. Creates a clipping boundary with no actual data assigned.
Public method ClipBoundary2d(Point2dCollection)
Constructor for the ClipBoundary2d class. Creates a clipping boundary from the given points.
Public method ClipBoundary2d(Point2d, Point2d)
Constructor for the ClipBoundary2d class. Creates a rectangular clipping boundary from the given two corner points.
Top
Properties
  Name Description
Top
Methods
  Name Description
Public method ClipPolygon
Clips a polygon formed by the passed points.
Public method ClipPolyline
Clips a polyline formed by the passed points.
Public methodStatic member Create
Creates a CircularArc2d object based on the passed pointer.
Public method Set(Point2dCollection)
Sets the clip boundary with the specified points.
Public method Set(Point2d, Point2d)
Resets the object to a rectangular clipping boundary.
Top
See Also

©  Bricsys NV. All rights reserved.