Arc Constructor (Point3d, Vector3d, Double, Double,
Double)
|
Initializes a new instance of the
Arc class
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public Arc(
Point3d center,
Vector3d normal,
double radius,
double startAngle,
double endAngle
)
Public Sub New (
center As Point3d,
normal As Vector3d,
radius As Double,
startAngle As Double,
endAngle As Double
)
public:
Arc(
Point3d center,
Vector3d normal,
double radius,
double startAngle,
double endAngle
)
new :
center : Point3d *
normal : Vector3d *
radius : float *
startAngle : float *
endAngle : float -> Arc
Parameters
- center
- Type: Teigha.GeometryPoint3d
- normal
- Type: Teigha.GeometryVector3d
- radius
- Type: SystemDouble
- startAngle
- Type: SystemDouble
- endAngle
- Type: SystemDouble
See Also