Vector3dRotateBy Method

Rotates this vector by the specified angle about the specified axis.
Namespace:  Teigha.Geometry
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public Vector3d RotateBy(
        double angle,
        Vector3d axis
)

Parameters

angle
Type: SystemDouble
[in] Angle in radians.
axis
Type: Teigha.GeometryVector3d
[in] Axis of rotation.

Return Value

Type: Vector3d
Rotated vector.
See Also

©  Bricsys NV. All rights reserved.