AssocArrayAddSourceEntity Method
|
Appends the specified entity to the list of
source items. The added source entity is sent to a hidden locked
layer and is managed by the corresponding action.
Namespace: Teigha.DatabaseServices
Assembly: TD_MgdDbConstraints (in
TD_MgdDbConstraints.dll) Version: 0.0.0.0
Syntax
public void AddSourceEntity(
ObjectId sourceEntity,
Point3d basePoint
)
Public Sub AddSourceEntity (
sourceEntity As ObjectId,
basePoint As Point3d
)
public:
void AddSourceEntity(
ObjectId sourceEntity,
Point3d basePoint
)
member AddSourceEntity :
sourceEntity : ObjectId *
basePoint : Point3d -> unit
Parameters
- sourceEntity
- Type: Teigha.DatabaseServicesObjectId
[in] Source entity to add.
- basePoint
- Type: Teigha.GeometryPoint3d
[in] Point that is used as a reference to position the newly added
source entity.
See Also