AssocArray Class

This .NET class wraps the OdDbAssocArrayActionBody class.

It contains the identifier of the associative array and the identifier of the associative array's corresponding AcDbAssocArrayActionBody object that is used for evaluating the array's parameters.

The stored AssocArrayParameters object manages parameters of the associative array.

Inheritance Hierarchy
SystemObject
  Teigha.DatabaseServicesAssocArray
Namespace:  Teigha.DatabaseServices
Assembly:  TD_MgdDbConstraints (in TD_MgdDbConstraints.dll) Version: 0.0.0.0
Syntax
public class AssocArray

The AssocArray type exposes the following members.

Properties
  Name Description
Public property EntityId
Public property SourceEntities
Top
Methods
  Name Description
Public method AddSourceEntity
Appends the specified entity to the list of source items. The added source entity is sent to a hidden locked layer and is managed by the corresponding action.
Public methodStatic member CreateArray
Creates an associative array with the specified source entities, base point and parameters.
Public method DeleteItem
Marks the item at the specified index for erasing or un-erasing. When marked erased, the item is set to hidden state.
Public methodStatic member Explode
Gets the list of object identifiers from the exploded associative array, so each previous array element gets a unique identifier in the list.
Public methodStatic member GetAssociativeArray
Retrieves the associative array with the specified entity.
Public methodStatic member getItemLocators
Retrieves a list of item locators for the specified list of subentity paths of an associative array.
Public method getItems
Retrieves item locators from this associative array.
Public method GetItemTransform
Retrieves the transformation matrix applied to the array item at the specified index.
Public method GetParameters
Retrieves parameters of this associative array.
Public methodStatic member IsAssociativeArray
Checks whether the specified entity is an associative array.
Public method IsErased
Checks whether the item at the specified index is marked as erased.
Public method RemoveSourceEntity
Removes the source entity by its specified identifier and updates each item in the array that is controlled by the corresponding action.
Public method ReplaceItems
Public method ResetItems
Removes the item overrides, for example position, orientation, etc., from all items of this associative array.
Public method TransformItemBy
Applies a transform matrix to the item at the specified index.
Top
See Also

©  Bricsys NV. All rights reserved.