Curve3dGetArea Method (Double, Double, Tolerance)
|
Retrieves the area of the parametric interval
defined by the passed start and end parameters.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public double GetArea(
double startingParameter,
double endingParameter,
Tolerance tolerance
)
Public Function GetArea (
startingParameter As Double,
endingParameter As Double,
tolerance As Tolerance
) As Double
public:
double GetArea(
double startingParameter,
double endingParameter,
Tolerance tolerance
)
member GetArea :
startingParameter : float *
endingParameter : float *
tolerance : Tolerance -> float
Parameters
- startingParameter
- Type: SystemDouble
[in] Start of the parameter interval.
- endingParameter
- Type: SystemDouble
[in] End of the parameter interval (must be greater than
startingParameter).
- tolerance
- Type: Teigha.GeometryTolerance
[in] Geometric tolerance.
Return Value
Type:
Double
Area calculated between the specified parameters.
See Also