CircularArc3dProjectedIntersectWith Method (LinearEntity3d, Vector3d)

Retrieves intersection points between this circular arc and a projected line.
Namespace:  Teigha.Geometry
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public Point3d[] ProjectedIntersectWith(
        LinearEntity3d line,
        Vector3d projectionDirection
)

Parameters

line
Type: Teigha.GeometryLinearEntity3d
[in] Line to be projected.
projectionDirection
Type: Teigha.GeometryVector3d
[in] Projection direction.

Return Value

Type: Point3d
Array of intersection points.
See Also

©  Bricsys NV. All rights reserved.