NurbCurve3d Constructor (Int32, KnotCollection,
Point3dCollection, DoubleCollection, Boolean)
|
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public NurbCurve3d(
int degree,
KnotCollection knots,
Point3dCollection controlPoints,
DoubleCollection weights,
bool periodic
)
Public Sub New (
degree As Integer,
knots As KnotCollection,
controlPoints As Point3dCollection,
weights As DoubleCollection,
periodic As Boolean
)
public:
NurbCurve3d(
int degree,
KnotCollection^ knots,
Point3dCollection^ controlPoints,
DoubleCollection^ weights,
bool periodic
)
new :
degree : int *
knots : KnotCollection *
controlPoints : Point3dCollection *
weights : DoubleCollection *
periodic : bool -> NurbCurve3d
Parameters
- degree
- Type: SystemInt32
- knots
- Type: Teigha.GeometryKnotCollection
- controlPoints
- Type: Teigha.GeometryPoint3dCollection
- weights
- Type: Teigha.GeometryDoubleCollection
- periodic
- Type: SystemBoolean
See Also