NurbCurve3d Class

Inheritance Hierarchy
Namespace:  Teigha.Geometry
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public sealed class NurbCurve3d : SplineEntity3d

The NurbCurve3d type exposes the following members.

Constructors
  Name Description
Public method NurbCurve3d
Initializes a new instance of the NurbCurve3d class
Public method NurbCurve3d(EllipticalArc3d)
Initializes a new instance of the NurbCurve3d class
Public method NurbCurve3d(LineSegment3d)
Initializes a new instance of the NurbCurve3d class
Public method NurbCurve3d(Point3dCollection)
Initializes a new instance of the NurbCurve3d class
Public method NurbCurve3d(Point3dCollection, Tolerance)
Initializes a new instance of the NurbCurve3d class
Public method NurbCurve3d(Int32, PolylineCurve3d, Boolean)
Initializes a new instance of the NurbCurve3d class
Public method NurbCurve3d(Point3dCollection, Vector3dCollection, Boolean)
Initializes a new instance of the NurbCurve3d class
Public method NurbCurve3d(Int32, KnotCollection, Point3dCollection, Boolean)
Initializes a new instance of the NurbCurve3d class
Public method NurbCurve3d(Point3dCollection, Vector3dCollection, Tolerance, Boolean)
Initializes a new instance of the NurbCurve3d class
Public method NurbCurve3d(Int32, KnotCollection, Point3dCollection, DoubleCollection, Boolean)
Initializes a new instance of the NurbCurve3d class
Public method NurbCurve3d(Point3dCollection, Vector3d, Vector3d, Boolean, Boolean)
Initializes a new instance of the NurbCurve3d class
Public method NurbCurve3d(Point3dCollection, Vector3d, Vector3d, Boolean, Boolean, KnotParameterizationEnum)
Initializes a new instance of the NurbCurve3d class
Public method NurbCurve3d(Point3dCollection, Vector3d, Vector3d, Boolean, Boolean, Tolerance)
Initializes a new instance of the NurbCurve3d class
Public method NurbCurve3d(Point3dCollection, Vector3d, Vector3d, Boolean, Boolean, KnotParameterizationEnum, Tolerance)
Initializes a new instance of the NurbCurve3d class
Top
Properties
  Name Description
Public property DefinitionData
Public property EvalMode
Public property FitData
Public property FitKnotParameterization
Public property FitTolerance
Public property NumFitPoints
Public property NumWeights
Top
Methods
  Name Description
Public method AddControlPointAt
Public method AddFitPointAt
Public method AddKnot
Public methodStatic member Create
Public method DeleteControlPointAt
Public method DeleteFitPointAt
Public method ElevateDegree
Public method GetFitPointAt
Public method GetFitTangents
Public method GetParametersOfC1Discontinuity
Public method GetParametersOfC1Discontinuity(Tolerance)
Public method GetParametersOfG1Discontinuity
Public method GetParametersOfG1Discontinuity(Tolerance)
Public method GetWeightAt
Public method HardTrimByParams
Public method InsertKnot
Public method JoinWith
Public method MakeClosed
Public method MakeNonPeriodic
Public method MakeOpen
Public method MakePeriodic
Public method MakeRational
Public method PurgeFitData
Public method SetEvaluateMode
Public method SetFitData(Int32, Point3dCollection)
Public method SetFitData(Int32, Point3dCollection, Tolerance)
Public method SetFitData(Point3dCollection, Vector3d, Vector3d)
Public method SetFitData(Point3dCollection, Vector3d, Vector3d, Tolerance)
Public method SetFitData(KnotCollection, Point3dCollection, Vector3d, Vector3d, Boolean)
Public method SetFitData(Point3dCollection, Vector3d, Vector3d, KnotParameterizationEnum, Tolerance)
Public method SetFitData(KnotCollection, Point3dCollection, Vector3d, Vector3d, Tolerance, Boolean)
Public method SetFitPointAt
Public method SetFitTangents
Public method SetWeightAt
Top
See Also

©  Bricsys NV. All rights reserved.