RadialDimensionLarge Constructor (Point3d, Point3d, Point3d,
Point3d, Double, String, ObjectId)
|
Constructor. Creates a RadialDimensionLarge
object with specified parameters.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public RadialDimensionLarge(
Point3d center,
Point3d chordPoint,
Point3d overrideCenter,
Point3d jogPoint,
double jogAngle,
string dimensionText,
ObjectId dimensionStyle
)
Public Sub New (
center As Point3d,
chordPoint As Point3d,
overrideCenter As Point3d,
jogPoint As Point3d,
jogAngle As Double,
dimensionText As String,
dimensionStyle As ObjectId
)
public:
RadialDimensionLarge(
Point3d center,
Point3d chordPoint,
Point3d overrideCenter,
Point3d jogPoint,
double jogAngle,
String^ dimensionText,
ObjectId dimensionStyle
)
new :
center : Point3d *
chordPoint : Point3d *
overrideCenter : Point3d *
jogPoint : Point3d *
jogAngle : float *
dimensionText : string *
dimensionStyle : ObjectId -> RadialDimensionLarge
Parameters
- center
- Type: Teigha.GeometryPoint3d
Center point of the circle or arc to be measured.
- chordPoint
- Type: Teigha.GeometryPoint3d
Chord point on the circle or arc to be measured, and to which the
dimension line is drawn.
- overrideCenter
- Type: Teigha.GeometryPoint3d
Origin point from which the dimension line is drawn.
- jogPoint
- Type: Teigha.GeometryPoint3d
Point at which the dimension line jogs when it passes from the
override point to the chord point.
- jogAngle
- Type: SystemDouble
Jog angle between the line through the overridden center point and
line through the jog point.
- dimensionText
- Type: SystemString
Dimension text to replace the measured value text.
- dimensionStyle
- Type: Teigha.DatabaseServicesObjectId
ObjectId of the dimension style that is used to draw the dimension
entity.
See Also