RadialDimensionLarge Class

Wraps the OdDbRadialDimensionLarge class. Represents large (jogged) radial dimension entities.
Inheritance Hierarchy
Namespace:  Teigha.DatabaseServices
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public class RadialDimensionLarge : Dimension

The RadialDimensionLarge type exposes the following members.

Constructors
  Name Description
Public method RadialDimensionLarge
Default constructor. Creates the radial large dimension entity with the center, overridden center, jog and chord points at (0, 0, 0) and the jog angle of 0.785398 (PI/4).
Protected method RadialDimensionLarge(IntPtr, Boolean)
Initializes a new instance of the RadialDimensionLarge class
Public method RadialDimensionLarge(Point3d, Point3d, Point3d, Point3d, Double, String, ObjectId)
Constructor. Creates a RadialDimensionLarge object with specified parameters.
Top
Properties
  Name Description
Public property Center
Sets or gets the three-dimensional WCS coordinates that define the center point of the arc or circle being dimensioned.
Public property ChordPoint
Sets or gets the three-dimensional WCS coordinates that define the intersection point of the dimension line and the arc or circle to be dimensioned.
Public property Dimalttz
Sets or gets the suppression of zeros in alternate tolerance values in dimension.
Value Description
0 Suppresses zero feet and zero inches.
1 Includes zero feet and zero inches.
2 Suppresses zero inches and includes zero feet.
3 Suppresses zero feet and includes zero inches.
4 Suppresses leading zeros.
8 Suppresses trailing zeros.
Public property Dimaltu
Sets or gets the format of alternate units.
Value Description
1 Scientific format.
2 Decimal format.
3 Engineering format.
4 Architectural (stacked) format.
5 Fractions (stacked) format.
6 Architectural format.
7 Fractions format.
Public property Dimaltz
Sets or gets the suppression of zeros in alternate measurements in dimensions.
Value Description
0 Suppresses zero feet and zero inches
1 Includes zero feet and zero inches.
2 Suppresses zero inches and includes zero feet.
3 Suppresses zero feet and includes zero inches.
4 Suppresses leading zeros.
8 Suppresses trailing zeros.
Public property Dimatfit
Sets or gets how arrows and text are placed when they do not fit within the extension lines of dimensions.
Value Description
0 Moves both text and arrowheads outside of extension lines.
1 Moves arrowheads outside of extension lines and text is placed between extension lines.
2 Moves text outside of extension lines and arrowheads are placed between extension lines.
Public property Dimaunit
Sets or gets the format for the angular measured value and angular tolerance value.
Value Description
0 Decimal degrees.
1 Degrees, minutes, and seconds.
2 Gradians.
Public property Dimazin
Sets or gets the suppression of zeros in angular measured values and tolerance.
Value Description
0 Includes all leading and trailing zeros.
1 Suppresses leading zeros.
2 Suppresses trailing zeros.
Public property Dimblk2s
Sets or gets the name of the arrowhead block at the end of the second dimension line. The following names are applicable:
Value Description
"None" None
"Closed" Closed
"Dot" Dot
"ClosedBlank" Closed blank
"Oblique" Oblique
"ArchTick" Architectural tick
"Open" Open
"Origin" Origin marker
"Origin2" Origin marker 2
"Open90" Open 90 degrees
"Open30" Open 30 degrees
"DotBlank" Dot blank
"DotSmall" Dot small
"BoxFilled" Box filled
"BoxBlank" Box blank
"DatumFilled" Datum marker filled
"DatumBlank" Datum marker blank
"Integral" Integral
"Small" Dot small blank
Public property Dimblks
Sets or gets the name of the arrowhead block at the ends of dimension lines. The following names are applicable:
Value Description
"None" None
"Closed" Closed
"Dot" Dot
"ClosedBlank" Closed blank
"Oblique" Oblique
"ArchTick" Architectural tick
"Open" Open
"Origin" Origin marker
"Origin2" Origin marker 2
"Open90" Open 90 degrees
"Open30" Open 30 degrees
"DotBlank" Dot blank
"DotSmall" Dot small
"BoxFilled" Box filled
"BoxBlank" Box blank
"DatumFilled" Datum marker filled
"DatumBlank" Datum marker blank
"Integral" Integral
Public property Dimjust
Sets or gets the horizontal justification for the dimension text box (relative to the extension lines).
Value Description
0 The text is centered within the extension lines.
1 The text is by the first extension line.
2 The text is by the second extension line.
3 The text is above the dimension line, parallel to the first extension line.
Public property Dimldrblks
Sets or gets the name of the arrowhead block at the ends of leader lines. The following names are applicable:
Value Description
"None" None
"Closed" Closed
"Dot" Dot
"ClosedBlank" Closed blank
"Oblique" Oblique
"ArchTick" Architectural tick
"Open" Open
"Origin" Origin marker
"Origin2" Origin marker 2
"Open90" Open 90 degrees
"Open30" Open 30 degrees
"DotBlank" Dot blank
"DotSmall" Dot small
"BoxFilled" Box filled
"BoxBlank" Box blank
"DatumFilled" Datum marker filled
"DatumBlank" Datum marker blank
"Integral" Integral
Public property Dimtad
Sets or gets the vertical justification for the dimension text.
Value Description
0 The dimension text is centered vertically between two parts of the dimension line.
1 The dimension text is placed above the dimension line, except when the dimension line is not horizontal and the dimension text box is aligned horizontally.
2 The dimension text box is placed on the side of the dimension line farthest from the defining point.
3 The dimension text is positioned according to Japanese Industrial Standards.
Public property Dimtzin
Sets or gets the suppression of zeros in primary tolerance values in dimension.
Value Description
0 Suppresses zero feet and zero inches.
1 Includes zero feet and zero inches.
2 Suppresses zero inches and includes zero feet.
3 Suppresses zero feet and includes zero inches.
4 Suppresses leading zeros.
8 Suppresses trailing zeros.
Public property JogAngle
Sets or gets the jog angle (the angle between the line through the overridden center point and line through the jog point) in radians.
Public property JogPoint
Sets or gets the three-dimensional WCS coordinates that define the jog point. A jog point is the point at which the dimension line jogs when it passes from the override point to the chord point.
Public property OverrideCenter
Sets or gets the three-dimensional WCS coordinates that define the origin point from which the dimension line is drawn.
Top
Methods
  Name Description
Top
Events
  Name Description
Top
See Also

©  Bricsys NV. All rights reserved.