Curve2dGetSamplePoints Method (Double, Double, Double)

Retrieves specified arrays of sample points along this curve and their parameter values.
Namespace:  Teigha.Geometry
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public PointOnCurve2d[] GetSamplePoints(
        double fromParameter,
        double toParameter,
        double approxEps
)

Parameters

fromParameter
Type: SystemDouble
[in] First parameter value that represents the start of the interval.
toParameter
Type: SystemDouble
[in] Second parameter value that represents the end of the interval.
approxEps
Type: SystemDouble
[in] Approximation spacing (step) along a parametric range.

Return Value

Type: PointOnCurve2d
Array of sample points.
See Also

©  Bricsys NV. All rights reserved.