PointOnCurve2d Class |
The PointOnCurve2d type exposes the following members.
Name | Description | |
---|---|---|
![]() |
PointOnCurve2d |
Initializes a new instance of the PointOnCurve2d class
|
![]() |
PointOnCurve2d(Curve2d) |
Initializes a new instance of the PointOnCurve2d class
|
![]() |
PointOnCurve2d(Curve2d, Double) |
Initializes a new instance of the PointOnCurve2d class
|
Name | Description | |
---|---|---|
![]() |
AutoDelete | (Inherited from DisposableWrapper.) |
![]() |
Curve | |
![]() |
IsDisposed | (Inherited from DisposableWrapper.) |
![]() |
Parameter | |
![]() |
Point | |
![]() |
UnmanagedObject | (Inherited from DisposableWrapper.) |
Name | Description | |
---|---|---|
![]() |
Clone | (Inherited from Entity2d.) |
![]() ![]() |
Create | |
![]() |
CreateObjRef |
Creates an object that contains all the
relevant information required to generate a proxy used to
communicate with a remote object.
(Inherited from MarshalByRefObject.) |
![]() |
Dispose | (Inherited from DisposableWrapper.) |
![]() |
Equals | (Inherited from DisposableWrapper.) |
![]() |
GetDerivative(Int32) | |
![]() |
GetDerivative(Int32, Double) | |
![]() |
GetDerivative(Int32, Curve2d, Double) | |
![]() |
GetHashCode | (Inherited from DisposableWrapper.) |
![]() |
GetLifetimeService |
Retrieves the current lifetime service object
that controls the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() |
GetPointAtParameter | |
![]() |
GetPointOnCurve | |
![]() |
GetType |
Gets the Type of the current instance.
(Inherited from Object.) |
![]() |
InitializeLifetimeService |
Obtains a lifetime service object to control
the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() |
IsEqualTo(Entity2d) | (Inherited from Entity2d.) |
![]() |
IsEqualTo(Entity2d, Tolerance) | (Inherited from Entity2d.) |
![]() |
IsOn(Point2d) | (Inherited from Entity2d.) |
![]() |
IsOn(Point2d, Tolerance) | (Inherited from Entity2d.) |
![]() |
Mirror | (Inherited from Entity2d.) |
![]() |
RotateBy | (Inherited from Entity2d.) |
![]() |
ScaleBy | (Inherited from Entity2d.) |
![]() |
ToString |
Returns a string that represents the current
object.
(Inherited from Object.) |
![]() |
TransformBy | (Inherited from Entity2d.) |
![]() |
TranslateBy | (Inherited from Entity2d.) |
© Bricsys NV. All rights reserved. |