Exception Class |
The Exception type exposes the following members.
Name | Description | |
---|---|---|
![]() |
Exception |
Initializes a new instance of the Exception class
|
![]() |
Exception(ErrorStatus) |
Initializes a new instance of the Exception class
|
![]() |
Exception(SerializationInfo, StreamingContext) |
Initializes a new instance of the Exception class
|
![]() |
Exception(ErrorStatus, String) |
Initializes a new instance of the Exception class
|
![]() |
Exception(ErrorStatus, String, Exception) |
Initializes a new instance of the Exception class
|
Name | Description | |
---|---|---|
![]() |
Data |
Gets a collection of key/value pairs that
provide additional user-defined information about the
exception.
(Inherited from Exception.) |
![]() |
ErrorStatus | |
![]() |
HelpLink |
Gets or sets a link to the help file
associated with this exception.
(Inherited from Exception.) |
![]() |
HResult |
Gets or sets HRESULT, a coded numerical value
that is assigned to a specific exception.
(Inherited from Exception.) |
![]() |
InnerException |
Gets the Exception instance that caused the current
exception.
(Inherited from Exception.) |
![]() |
Message |
Gets a message that describes the current
exception.
(Inherited from Exception.) |
![]() |
Source |
Gets or sets the name of the application or
the object that causes the error.
(Inherited from Exception.) |
![]() |
StackTrace |
Gets a string representation of the immediate
frames on the call stack.
(Inherited from Exception.) |
![]() |
TargetSite |
Gets the method that throws the current
exception.
(Inherited from Exception.) |
Name | Description | |
---|---|---|
![]() |
Equals | (Inherited from Object.) |
![]() |
Finalize |
Allows an object to try to free resources and
perform other cleanup operations before it is reclaimed by garbage
collection.
(Inherited from Object.) |
![]() |
GetBaseException |
When overridden in a derived class, returns
the Exception that is the root cause of one or more
subsequent exceptions.
(Inherited from Exception.) |
![]() |
GetHashCode |
Serves as a hash function for a particular
type.
(Inherited from Object.) |
![]() |
GetObjectData | (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext).) |
![]() |
GetType |
Gets the runtime type of the current
instance.
(Inherited from Exception.) |
![]() |
MemberwiseClone |
Creates a shallow copy of the current Object.
(Inherited from Object.) |
![]() |
ToString |
Creates and returns a string representation of
the current exception.
(Inherited from Exception.) |
Name | Description | |
---|---|---|
![]() |
SerializeObjectState |
Occurs when an exception is serialized to
create an exception state object that contains serialized data
about the exception.
(Inherited from Exception.) |
© Bricsys NV. All rights reserved. |