NurbSurfaceSet Method (Int32, Int32, Int32, Int32, Int32, Int32,
Point3dCollection, DoubleCollection, KnotCollection,
KnotCollection, Tolerance)
|
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public void Set(
int degreeU,
int degreeV,
int propsInU,
int propsInV,
int numControlPointsInU,
int numControlPointsInV,
Point3dCollection controlPoints,
DoubleCollection weights,
KnotCollection knotsInU,
KnotCollection knotsInV,
Tolerance tolerance
)
Public Sub Set (
degreeU As Integer,
degreeV As Integer,
propsInU As Integer,
propsInV As Integer,
numControlPointsInU As Integer,
numControlPointsInV As Integer,
controlPoints As Point3dCollection,
weights As DoubleCollection,
knotsInU As KnotCollection,
knotsInV As KnotCollection,
tolerance As Tolerance
)
public:
void Set(
int degreeU,
int degreeV,
int propsInU,
int propsInV,
int numControlPointsInU,
int numControlPointsInV,
Point3dCollection^ controlPoints,
DoubleCollection^ weights,
KnotCollection^ knotsInU,
KnotCollection^ knotsInV,
Tolerance tolerance
)
member Set :
degreeU : int *
degreeV : int *
propsInU : int *
propsInV : int *
numControlPointsInU : int *
numControlPointsInV : int *
controlPoints : Point3dCollection *
weights : DoubleCollection *
knotsInU : KnotCollection *
knotsInV : KnotCollection *
tolerance : Tolerance -> unit
Parameters
- degreeU
- Type: SystemInt32
- degreeV
- Type: SystemInt32
- propsInU
- Type: SystemInt32
- propsInV
- Type: SystemInt32
- numControlPointsInU
- Type: SystemInt32
- numControlPointsInV
- Type: SystemInt32
- controlPoints
- Type: Teigha.GeometryPoint3dCollection
- weights
- Type: Teigha.GeometryDoubleCollection
- knotsInU
- Type: Teigha.GeometryKnotCollection
- knotsInV
- Type: Teigha.GeometryKnotCollection
- tolerance
- Type: Teigha.GeometryTolerance
See Also